FedEx experiencing issues
Incident Report for Infoplus
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 10:02 CST
Investigating
FedEx is experiencing degraded performance. Please refer to their status page for further updates.
Posted Mar 04, 2024 - 11:11 CST
This incident affected: Infoplus Web Application, Infoplus API, and Infoplus Mobile Floor Apps.