EasyPost experiencing shipping issues
Incident Report for Infoplus
Resolved
EasyPost has resolved this issue and users should no longer experience any shipping issues.
Posted Feb 27, 2024 - 20:19 CST
Identified
EasyPost is experiencing an issue that is causing the following error to show during shipping: "An upstream service failed when responding to our requests please try again or contact support." EasyPost is aware and is working on the issue. We thank you for your patience while they work to correct the issue and will provide updates here.
Posted Feb 27, 2024 - 15:43 CST
This incident affected: Infoplus Web Application and Infoplus Mobile Floor Apps.