Amazon Web Services (AWS) Service Outage

Incident Report for InfoPlus

Postmortem

Post-Incident Summary – Amazon Web Services (AWS) Service Outage
Date of Incident: October 20th, 2025

Overview
Yesterday, October 20th, 2025, InfoPlus experienced intermittent service disruptions due to a widespread outage affecting several Amazon Web Services (AWS) services. This issue temporarily impacted portions of our platform, including but not limited to: Insert & Update Triggers, Audits, Parcel Labels, Shopping Cart Connections, and Order Emails.

What Happened
Between approximately 2:00 AM CST and 3:00 PM CST, AWS experienced an infrastructure-level issue that caused intermittent connectivity and performance degradation across multiple regions. Because InfoPlus relies on AWS to host and operate key services, this upstream issue resulted in delays and temporary errors within our platform.

InfoPlus engineers were alerted overnight and immediately began investigating and implementing measures to restore service to impacted areas. While the root cause was within AWS infrastructure, our team worked throughout the early morning hours to stabilize affected systems and minimize customer impact where possible.

AWS engineers identified and resolved the underlying issue, and InfoPlus systems began recovering by 9:00 AM CST. Full stability was confirmed by late morning to early afternoon, and all services have remained healthy since.

Current Status
All InfoPlus services are now operating normally. Monitoring confirms system stability and performance have returned to expected levels.

Next Steps
While this issue originated with AWS, we are taking additional steps to minimize the impact of similar upstream incidents in the future, including:

  • Reviewing cross-region and redundancy options for critical services.
  • Continuing to refine our communication processes to keep customers informed throughout incidents.

Thank You
We sincerely appreciate your patience and understanding while we worked through this issue alongside AWS.

If you continue to experience any related issues or have questions, please contact our support team at https://www.infopluscommerce.com/support/new-ticket.

Posted Oct 21, 2025 - 10:00 CDT

Resolved

AWS has confirmed full resolution of their earlier outage, and all InfoPlus systems continue to operate normally. We have not observed any new issues, and all services remain fully functional.

This incident is now considered resolved. Our team will continue to monitor performance to ensure continued stability across all systems.

A detailed post-mortem outlining the impact, timeline, and follow-up actions will be published on our status page and distributed via email tomorrow, October 21st, 2025.

For those interested in more technical details regarding the AWS outage itself, please visit the AWS Service Health Dashboard found here: https://health.aws.amazon.com/health/status.

Thank you for your patience and understanding while we worked through this issue alongside AWS. If you experience any lingering issues, please contact our support team at https://www.infopluscommerce.com/support/new-ticket.
Posted Oct 20, 2025 - 18:05 CDT

Update

All InfoPlus systems have remained stable and are now fully operational. We have not observed any new issues, and all services continue to function as expected.

While our cloud provider, AWS, has not yet marked their incident as fully resolved, InfoPlus systems are performing normally. Our team will continue to monitor closely until AWS confirms full restoration.

We will provide an update - and potentially mark this incident as resolved - as soon as AWS confirms full recovery or additional information becomes available.

If you experience any lingering issues, please reach out to our support team at https://www.infopluscommerce.com/support/new-ticket.
Posted Oct 20, 2025 - 16:00 CDT

Update

Systems have continued to remain stable as our cloud provider, AWS, works toward a full resolution of the earlier outage. We have not observed any new issues, and all previously affected services continue to operate normally.

Our team remains in close contact with AWS and will continue to monitor the situation closely. If you’re still experiencing any related issues, please reach out to our support team at https://www.infopluscommerce.com/support/new-ticket.

We’ll provide another update by 4:00 PM CST, or sooner if there are any significant changes.
Posted Oct 20, 2025 - 14:11 CDT

Update

Following earlier disruptions this morning, systems have remained stable as our cloud provider, AWS, continues working toward a full resolution of the outage. We have not observed any new issues, and affected services are operating normally at this time.

Our team remains in close contact with AWS and will continue to monitor the situation closely. If you’re still experiencing any related issues, please reach out to our support team at https://www.infopluscommerce.com/support/new-ticket.

We’ll provide another update by 2:00 PM CST, or sooner if there are any significant changes.
Posted Oct 20, 2025 - 12:00 CDT

Update

We continue to monitor the situation closely as our cloud provider, AWS, works toward a full resolution of the earlier outage. Systems have remained stable over the past hour, and we’re maintaining increased visibility across all affected services to ensure continued recovery.

If you’re still experiencing any related issues, please reach out to our support team at https://www.infopluscommerce.com/support/new-ticket for assistance.

We’ll provide another update by 12:00 PM CST, or sooner if there are any significant changes.
Posted Oct 20, 2025 - 11:00 CDT

Update

We are beginning to see signs of recovery as our cloud provider, AWS, continues to address the underlying outage. While overall system stability is improving, some services may continue to experience intermittent issues.

The affected areas include, but are not limited to: Insert & Update Triggers, Audits, Parcel Labels, Shopping Cart Connections, and Order Emails.

Our team is continuing to monitor closely and is coordinating with AWS. We will share another update by 11:00 AM CST or sooner if additional progress is made.
Posted Oct 20, 2025 - 09:45 CDT

Monitoring

Our cloud provider continues to experience an outage causing intermittent issues across multiple services impacting our systems.

Our team is closely monitoring the situation and remains in contact with the provider for updates.

While there is currently no estimated resolution time, we will provide another update by 10:00 AM CST or sooner if new information becomes available.
Posted Oct 20, 2025 - 08:50 CDT

Identified

Our cloud provider is experiencing an outage that may affect service performance and availability.

We’re actively investigating and will provide another update no later than 9:00 AM CST.
Posted Oct 20, 2025 - 08:03 CDT
This incident affected: Infoplus Web Application, Infoplus API, and Infoplus Mobile Floor Apps.