EasyPost experiencing issues buying and rating UPS shipments
Incident Report for InfoPlus
Resolved
EasyPost's operations have returned to full capacity.
Posted May 17, 2024 - 16:50 CDT
Investigating
EasyPost has identified an issue on their end causing problems buying and rating UPS shipments. Please refer to their status page here for further updates: https://www.easypoststatus.com/
Posted May 17, 2024 - 14:19 CDT
This incident affected: Infoplus API and Infoplus Mobile Floor Apps.