Degraded FedEx Rating Performance

Incident Report for InfoPlus

Resolved

FedEx's operations have returned to normal.
Posted Nov 27, 2023 - 09:33 CST

Investigating

FedEx is experiencing a performance issue rating shipments. Be sure to check FedEx's status page for updates if this is affecting you.
Posted Nov 24, 2023 - 12:42 CST