Intermittent instances of delayed shipping label generation
Incident Report for Infoplus
Resolved
We are pleased to announce the resolution of the shipping label generation issue that some of our users experienced starting from February 26, 2024, at 17:38:43.820, which persisted until March 12, 2024, at 18:21:50.350. After a detailed investigation, our team identified that the core of the problem was related to processing delays at our partner’s, EasyPost, instance of AWS.

We encountered some challenges with receiving timely updates from our partner, but through diligent monitoring and analysis, we have observed that the issue has been effectively resolved, with no further instances reported as of March 12th. In our commitment to ensuring a seamless experience for our users, we have proactively implemented additional safeguards designed to preemptively address any potential future disruptions related to label generation processing times.

It’s important to note that our clients utilizing eHub services were not affected by this issue, thanks to a specialized workaround that had already been implemented by the eHub team.

We want to extend our sincerest appreciation for your patience and trust as we navigated and ultimately resolved this challenge within our ecosystem. Ensuring the reliability and efficiency of your operations remains our top priority.

Should you have any further concerns or require assistance, please do not hesitate to reach out to our support team.

Thank you for your continued support.
Posted Mar 14, 2024 - 15:06 CDT
Investigating
We're aware of an uncommon issue sporadically occurring wherein users experience a delay in generating shipping labels when fulfilling. Our engineers are working with our partners to determine a solution.

If users are stuck on a specific fulfillment process/order and are unable to ship, contact support with a list of affected shipments and their corresponding orders. Our team will remove them, allowing you to continue your operations.

Note: Users using eHub will not experience this due to a workaround their team has implemented on their site.

Further updates will be shared here.
Posted Mar 08, 2024 - 09:40 CST
This incident affected: Infoplus Web Application, Infoplus API, and Infoplus Mobile Floor Apps.