UPS experiencing issues
Incident Report for Infoplus
Resolved
UPS has resolved the issue and shipments are functioning normally.
Posted Feb 20, 2024 - 12:34 CST
Update
We are continuing to work on a fix for this issue.
Posted Feb 20, 2024 - 09:08 CST
Identified
Users are reporting problems shipping with UPS. Please refer to UPS's status page for further information. We will monitor and provide updates as we learn of them.
Posted Feb 20, 2024 - 09:08 CST