FedEx experiencing server inconsistencies
Incident Report for InfoPlus
Resolved
FedEx's issues have been resolved.
Posted May 22, 2024 - 14:14 CDT
Investigating
FedEx is experiencing varying degrees of outages that are affecting EasyPost and ShipStation's ability to retrieve and generate FedEx Ground labels. Please refer to FedEx's status page for further information and updates.
Posted May 22, 2024 - 12:34 CDT
This incident affected: Infoplus Web Application, Infoplus Support Site, and Infoplus Mobile Floor Apps.