FedEx experiencing instability
Incident Report for Infoplus
Resolved
FedEx's operations have returned to normal service.
Posted Apr 04, 2024 - 18:24 CDT
Investigating
FedEx's services are experiencing instability and inconsistency. Please refer to their status page for more details. We will continue to monitor and update our own as needed.
Posted Apr 04, 2024 - 11:22 CDT
This incident affected: Infoplus Web Application and Infoplus Mobile Floor Apps.