Ticket form affected by Cloudware partial outage

Incident Report for InfoPlus

Resolved

The service that powers our ticket submission form appears to have resolved the issue.
Posted Jun 12, 2025 - 15:50 CDT

Identified

We've identified an issue that is causing our ticketing form to be unresponsive for some users. We're working with our partners to resolve this issue.

Please see https://www.cloudflarestatus.com/ for more details.
Posted Jun 12, 2025 - 13:53 CDT
This incident affected: Infoplus Support Site.