FedEx experiencing issues with shipments

Incident Report for InfoPlus

Resolved

FedEx operations have returned to normal; UPS is mostly normal. Refer to their status page for further information as needed.
Posted Nov 28, 2023 - 08:34 CST

Update

UPS Mail Innovations is also having issues with shipments and web traffic. As with FedEx, it is recommended to monitor their status page for further information.
Posted Nov 27, 2023 - 10:09 CST

Investigating

FedEx is experiencing issues with shipments and web traffic. It is recommended to monitor their status page for further information.
Posted Nov 27, 2023 - 09:48 CST