Infoplus Performance Degradation
Incident Report for Infoplus
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 12:13 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2020 - 11:28 CDT
Investigating
Infoplus is experiencing a performance degradation, which is negatively impacting our desktop, mobile, and API services.

We are investigating this and will provide an update as we learn more
Posted Jul 20, 2020 - 11:00 CDT
This incident affected: Infoplus Web Application and Infoplus API.